Microsoft Exchange 2013 – Réactiver les Server Component en Inactive State

Scenario

Après un upgrade via Cumulative Update sur Microsoft Exchange (failed ou success), il arrive qu’au redémarrage les Server Component deviennent inactifs.
Ceci arrive même si les services sont bien démarrés, le serveur refuse alors la connexion… le LoadBalancer nous le fait bien comprendre.

SubVS du LoadBalancer (Avant/Après)

Test

Un test simple est de vérifier que la page HTML du HealtCheck est bien accessible.
Pour ça il suffit d’ouvrir un navigateur internet et d’aller sur :

 https://<ExchangeFQDN>/<ExchangeService>/healthcheck.htm

Aucun problème de HealthCheck, la page HTML est accessible et renvoi un 200 OK



Problème HealthCheck, le service ne fonctionne pas correctement !

Solution

  • Ouvrir l’Exchange Management Shell
  • Vérifier l’état des Server Component via :
Get-ServerComponentState <ExchangeFQDN>

  • Activer les services un par un via :
Set-ServerComponentState -Identity <ExchangeFQDN> -Component <ServerComponent> -State Active -Requester HealthAPI

  • Il se peut qu’il faille essayer avec les différents Requester :
    • Maintenance
    • Sidelined
    • Functional
    • Deployment
  • Revérifier l’état des Server Component


...BofBienTrès BienTop ! (Soit le premier à voter)
Loading...

Mathieu

Je suis actuellement ingénieur spécialisé dans le design d'environnements cloud virtualisés. Adepte des technologies de VMware, Nutanix, Citrix et Microsoft je propose à travers ce blog diverses astuces de troubleshooting.

S’abonner
Notifier de
guest
2 Commentaires
le plus ancien
le plus récent le plus populaire
Inline Feedbacks
View all comments
Jibé
Jibé
4 mois il y a

Salut, je te remercie infiniment car je viens de réaliser une maintenance sur 4 exchange en load balancing sur deux hyperv et tes commandes m’ont permis de remettre tout d’équerre, 600 boites aux lettres j’avais pas le droit à l’erreur, grand merci encore ! 🙂